Documenting my Dosbox challenges (and hoping for help!)...
Ok - given that I was occasionally seeing this error when tracks had not changed - but theorizing that something in the DOSBOX/Game environment was getting out of sync...

I was adding tracks one-by-one to a fresh instance, and finally again saw the issue of sudden appearance of the "Unable to load TRACKS" error - despite having just worked.

When looking at the directory in DOSBOX (with the DIR command) - I saw a file at the bottom of the list that wasn't a track folder: DS_STO~1. After deleting that file (using the DEL command in DOSBOX), the sim again loaded as expected.

I don't know what that file is yet, but it appears to be the cause of at least SOME of these errors. (Not sure if its the existence of it, or a de-sync error - not sure where it comes from yet)
There is a limit to I think 28 tracks at one time. I make a folder called "temp_storage_for_tracks" and put all my temporarily not used tracks in there.
Yes, there is some limit for track folder. And it can cause Unable to load Tracks message. So I also have some temp folder for not used tracks.
Limit was 30 I think, or am I confusing that with N3?
IIRS Driver Champion (2005-2007, 2010-2014)
IIRS Team Champion (2004-2014)
Yes, the limit is 30. However, this is a separate issue that some have had when managing add-on tracks, unrelated to the 30-track limit. I'm on a Mac and it might be related to that - but for the people who have seen it they will know what I'm talking about.

This mystery file that appears in the TRACKS folder does not show up in Finder outside of DOSBOX (even when showing hidden files). And it can appear when there are any number of tracks in the TRACKS folder - including just the base tracks.

I'm watching to see if I can detect a pattern to when it appears - my hypothesis is its a DOSBOX item, not ICR2 game related. And its appearance does explain previous issues people have posted about on this sub where even after removing the track that "broke" the game, the error still appears.

But so far, the good news is that its deterministic. Any time it appears in TRACKS, the game will throw that config/memory "Unable to load tracks" error. And every time after deleting it, the game loads as normal.
Just for clarity for future users running into the "Unable to load TRACKS"'s what's worked for me.

From your base ICR2 folder in DOSBOX, run these commands:



<At this point you should see the DS_STO~1 at the bottom of your list of folders/files. If its there, that's what's causing the issue>


then you should be good to go

Forum Jump:

Users browsing this thread: 2 Guest(s)